Roslaunch ardrone_as action_server.launch

roslaunch ardrone_as action_server.launch will not run.

RLException: [action_server.launch] is neither a launch file in package [ardrone_as] nor is [ardrone_as] a launch file name
The traceback for the exception was written to the log file

Tried to use solution here: Ardrone_as launch
but I did not delete src folder.

catkin_make fails on ‘unit_5_services’ because ROS cannot find ‘iri_wam_reproduce_trajectory’

– ==> add_subdirectory(unit_5_services)
– Could NOT find iri_wam_reproduce_trajectory (missing: iri_wam_reproduce_trajectory_DIR)
– Could not find the required component ‘iri_wam_reproduce_trajectory’. The following CMake error indicates that you either need to install the package with the same name or change your environment so that it can be found.
CMake Error at /opt/ros/noetic/share/catkin/cmake/catkinConfig.cmake:83 (find_package):
Could not find a package configuration file provided by
“iri_wam_reproduce_trajectory” with any of the following names:


Add the installation prefix of “iri_wam_reproduce_trajectory” to
CMAKE_PREFIX_PATH or set “iri_wam_reproduce_trajectory_DIR” to a directory
containing one of the above files. If “iri_wam_reproduce_trajectory”
provides a separate development package or SDK, be sure it has been
Call Stack (most recent call first):
unit_5_services/CMakeLists.txt:10 (find_package)

– Configuring incomplete, errors occurred!
See also “/home/user/catkin_ws/build/CMakeFiles/CMakeOutput.log”.
See also “/home/user/catkin_ws/build/CMakeFiles/CMakeError.log”.
Invoking “cmake” failed

I’ve had the same problem, I’ve simply removed in the package unit_5_services all references to iri_warm

This allows me to run catkin_make without error.

I am still not able to:
roslaunch ardrone_as action_server.launch

I get the same error.

This suggests that roslaunch could not find the package ardrone_as. You can confirm that with:

roscd ardone_as

To fix, run the following command and try again:

source /home/simulations/public_sim_ws/devel/setup.bash


roslaunch ardrone_as action_server.launch

This works. Thank you for your help.

1 Like