Entity pushed to spawn queue but does not spawn in simulation

I’m having an issue with section 1.4 Spawn into Simulation. I have run the following command:

roslaunch my_mira_description spawn_mira_simple_collisions_inertias.launch

and I get the following output:

SpawnModel script started
[INFO] [1574821021.621107, 0.000000]: Loading model XML from ros parameter
[INFO] [1574821021.626993, 0.000000]: Waiting for service /gazebo/spawn_urdf_model
[INFO] [1574821021.632816, 0.000000]: Calling service /gazebo/spawn_urdf_model
[INFO] [1574821031.661599, 1138.582000]: Spawn status: SpawnModel: Entity pushed to spawn queue, but spawn service timed out waiting for entity to appear in simulation under the name mira
[urdf_spawner-1] process has finished cleanly
log file: /home/user/.ros/log/570d7002-10b9-11ea-8362-02a0146fd3d7/urdf_spawner-1*.log
all processes on machine have died, roslaunch will exit
shutting down processing monitor...
... shutting down processing monitor complete

The model never appears in Gazebo. I have tried resetting the simulation but I still get the same output. Any help would be appreciated.

Hello @acis.ubc,

May you send me your package/s so that I can check if there’s something wrong? You can send them to aezquerro@theconstructsim.com

Best,

Hello ,
I too have the same issue. I have been trying to figure it out for a whole day. Should I send in my package/s too?

Could you send us the files? duckfrost@theconstructsim.com. Also the command that you use to reproduce this issue and the unit where this happens. Thanks

I also had this problem @staff how can I solve this issue?

Thaks in advance

Hello Mr.Frost,

Wanted to know if the issue had been resolved. Eager to finish the lesson. Please do inform us when the problem has been resolved.
Sincerely,
Pravesh K Pradhan

Hello @pravesh.pradhan I also had this issue. And it may be not the most clever answer for you. But I tried to execute the command in the other day, without changing nothing…and it worked! And yes, I have refreshed and returned the for the first lesson of the course to refresh the system. The hint I could give is…refresh the system returning to the first lesson, pressing F5 to update the system, removing gazebo meshes and adding again, etc…or even log and unlog the site…
I hope be useful, for my case this worked…

Hello @marcusvini178 I will try it out. Thank you for reaching out.

Anyone had any luck solving this ?