Topics quiz: auto grader dosen't recognise that I am publishing or that I have subscribed

I am taking the ROS basics in 5 days course and I faced an issue with the auto-grader in unit 4. The auto-grader doesn’t recognize that I am publishing into /cmd_vel nor that I have subscribed to /kobuki/laser/scan. The auto-grader recognizes that the obstacle has been avoided. I’ve attached a screenshot that shows this.

I’ve tried running this quiz 4 times changing a few things, but none of them worked and I have 1 try left so any help would be great.

Hi, please make sure that you follow all of the specifications for the quiz, the grader might be catching those as errors because the name of the script, package is different:

*The name of the package where you’ll place all the code related to the Quiz will be topics_quiz.
*The name of the launch file that will start your program will be topics_quiz.launch.
*The name of the ROS node that will be launched by your program will be topics_quiz_node.
*Before correcting your Quiz, make sure that all your Python scripts are executalbe. They need to have full execution permissions in order to be executed by our autocorrection system. You can give them full execution permissions with the following command:
chmod +x

Hello @sujayshaunak ,

As my colleague indicates, it’s very important to carefully read the instructions of the notebook and also the Specifications section.

In your case, I believe the error is with the node name. As you can see in the Specifications, it says that the node name has to be topics_quiz_node. In your case, you are renaming the node of your program to Quiz in the launch file:

    <!-- My Package launch file -->
    <node pkg="topics_quiz" type="" name="Quiz"  output="screen">

So, you should change name="Quiz" to name="topics_quiz_node". If you fix this, the grader should work properly.


Hey, thanks for the information. I made the changes and re-submitted the code but it solved only a part of the problem. It still doesn’t recognize that I am publishing to cmd_vel.


Hi, I can see that you are indeed publishing to /cmd_vel. Could you try changing the name of your python file to If that doesn’t work, we’ll work on changing that grade for you.

1 Like

Unfortunately I have exhausted all my attempts at the quiz. So I want to check if it is possible to attempt once more, if not then please work on changing that grade for me.

Please try it once more. Go through the instructions once more and make sure all of the names are correct, and that your program works correctly. Then, make sure all programs are shut down before running the grader.

That worked. Thank you.

1 Like