Rosject project problems with local_setup.bash

I have some troubles starting the rosject of the course ROS2 in 5 days: when I type the first suggested line, I get what follows

I have just read these similar topics in the forum:

  1. Real Robot: Issue with local_setup.bash - #3 by Gorgo
  2. Error starting ros1_bridge - #2 by roalgoal

but they don’t help me to fix this issue. This is what it gives me:

Where is the problem? Which is the correct procedure to start the rosject? Thanks in advance

The ros1_bridge is only needed when using the real robot. Since the rosject simulation is already in ROS 2, you don’t need to run the bridge. Is that what’s happening here?

Try running the simulation and moving the robot with teleop (ros2 run teleop_twist_keyboard teleop_twist_keyboard). If it moves, you are ready to go

Hi @roalgoal,
thank you for your response.
I’m not able to start the simulation, these following lines

give me this:

Am I missing anything? And another question, I have to work inside the ros2_ws workspace or inside the simulation_ws one? Thanks in advance

You should work in ros2_ws.

Try launching it again from a new terminal, the one you are using might be confused with the multiple sourcing.

If it still doesn’t work, maybe something got changed in simulation_ws, so you can delete this rosject and fork a new copy with this link:

Thank you for your response.
I tried copying from your link, but the responses to the previous commands do not change:


If I run “ros2 launch turtlebot3_gazebo main_turtlebot3_lab.launch.xml” the simulation starts, even if the model is completely white (something is missing?)

However, even if it starts, how can I work inside the ros2_ws workspace if I cannot source the setup.bash after compiling it for any changes?
Thanks in advance

Please ignore this part, since the simulation loads fine without it. It’s probably a bug in the notebook.

No, nothing is missing, that’s the robot model color. However, I agree that using another color might be better.

Try cleaning the workspace and recompiling:

cd ~/ros2_ws
rm -rf build/ install/ log/
colcon build
source install/setup.bash

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.