Ros2 moveit_setup_assistant demo not showing robot and throwing some errors

I am tring to port moveo robotic arm to ros2 here is a ros1 implementation available.
but when I’ve tried to run the generated by ros2 launch moveit_setup_assistant robot is not showing in rviz.

and on the terminal I’ve got error

> [rviz2-4] [ERROR] [1679118932.635495154] [rviz]: Could not find parameter robot_description_semantic and did not receive robot_description_semantic via std_msgs::msg::String subscription within 10.000000 seconds.
> [rviz2-4] Error:   Could not parse the SRDF XML File. Error=XML_ERROR_EMPTY_DOCUMENT ErrorID=13 (0xd) Line number=0
> [rviz2-4]          at line 715 in ./src/model.cpp
> [rviz2-4] [ERROR] [1679118932.675279308] [moveit_rdf_loader.rdf_loader]: Unable to parse SRDF
> [rviz2-4] [ERROR] [1679118932.686935180] [moveit_ros.planning_scene_monitor.planning_scene_monitor]: Robot model not loaded

It worked only one time that is the first time after that it shows the same error every time.
I’ve also tried to create new server instance but same result.
project link here

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.