Ros2 in 5 Days Rosject

Hi, I have written a code that I am trying to test out in the gazebo simulation, but everytime I try to connect to the gazebo simulation like in the direction I get this warning message

[Wrn] [] Queue limit reached for topic /gazebo/default/physics/contacts, deleting message. This warning is printed only once.
I am also getting this error message

[Err] [] Missing model.config for model “/home/user/simulation_ws/src/turtlebot3/turtlebot3_simulations/turtlebot3_gazebo/models/turtlebot3_autorace_2020”. I don’t know what is going on.

The gazebo screen comes on but I am unable to launch my launch code.

Hi @flavelmm, welcome to the community!

What do you mean by “connect to the gazebo simulation”?

The warning and error message you are getting are not affecting the simulation itself. Do you see the simulation? Can you zoom out and see something?

Another way to check if your simulation is publishing information is to source ROS1 and check the topics, like so:

source /opt/ros/noetic/setup.bash
rostopic list

If you see an output, then that means it is working and you can go ahead and launch the ros1_bridge in order to connect the simulation (maybe this is what you meant) with ROS2

The problem is when I use this code:
source /opt/ros/noetic/setup.bash
source ~/simulation_ws/devel/setup.bash
roslaunch realrobotlab main.launch
When I use roslaunch line, I am unable to type anything into the shell and execute it. I get stuck at the warning and nothing else happens.

You shouldn’t have to type anything into the terminal. Have you tried closing it and opening a new one?
What happens when you open the gazebo window?

Have you tried zooming out (scroll down with your mouse wheel)? I’ve noticed that the gazebo simulation initializes in a state with camera positioned very close to the ground and directed downwards resulting in a blank grey screen on startup.