Ros basics in 5 days quiz launch issues

I ran the python file on its own, it works. However i seemed to have tried everything and i cannot seem to get the launch file to run the program properly. Hence i keep getting a zero on the quiz. Please help.

<node pkg="topics_quiz" type="" name="topics_quiz_node" output="screen" />
![Screen Shot 2021-02-25 at 7.17.58 PM|690x493](upload://iWDlIOceyARySez6qpb4TfVGbl2.png)

Hello @ConoSammarco ,

We cannot see the image you shared. Could you maybe paste here the error message you are getting when running the launch file?


my apologies, here is the error message:

RLException: [topics_quiz.launch] is neither a launch file in package [topics_quiz] nor is [topics_quiz] a launchfile name
The traceback for the exception was written to the log file

Hello @ConoSammarco ,

The reason for this error is because you don’t have any ROS package named topics_quiz. You do have a folder named topics_quiz, but that’s not the ROS package name. If you check, for instance, the package.xml file, you will see the ROS package name in the <name> tag:

<?xml version="1.0"?>
<package format="2">

In this case, the package name is tutorial. You can also find the ROS package name in the CMakeLists.txt file, line 2:


I suggest you create the package from zero, following the instructions explained in previous lessons, and then you can copy the Python script and launch files to the new package.