Real Robot Lab: Robot stuck and Teleop doesnt work

I tested my wall follower module in simulation as part of realrobotlab ROSJECT and runs continuously in simulation without stopping.
So I tried booking a real robot slot for 30 mins. I was able to start my program. The robot got stuck in the corner. Usually I have a routine to back off when stuck but it doesnt seem to kick in.
So I tried connecting Teleop routine to manually move the robot. But it doesn’t seem to work either. Any clues?

I developed my wall follower module as part of the ROS2 basics in 5 days course if that helps.



I will look into this. Did you run

source /opt/ros/noetic/setup.bash
source /opt/ros/foxy/setup.bash
ros2 run ros1_bridge dynamic_bridge --bridge-all-topics

in a separate terminal from the teleop?

The Teleop started working after a while, though I couldn’t figure what made the difference.

Right now i am trying to tune the velocities and distance thresholds as the values i had in simulation don’t seem to produce same robot behavior in real lab.

I am out of my weekly quota. However I don’t see anyone using the robot lab last 2 days. So maybe you can allow ppl to reserve more slots if no one has reserved 5 min before the slot is to begin.


Absolutely. We want more people to use the lab, so just let me know when you want another slot and I can give you more in the database. We are also working on combining 2 25 minute sessions into a 55 minute session since we’ve seen most users reserve the lab back to back.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.