Question on Unit-3-topics - Not able to deploy Topic "/counter"


  1. I followed the exercise and deployed all the steps including, creating launch file, making the file executable, etc. I don’t get any error in any step, however i dont see the topic “/counter” . The output of “ros2 topic list | grep ‘/counter’” does not show “/counter” but it has other topics from previous units. Does anything missing in the exercises/unit? Please help.
  2. Also, do you recommend any book to get better at C++ coding for robotics. I’m beginner in C++ programming and your examples are little over my head in terms of picking up programing concepts. please suggest.


  1. Make sure you follow the steps from the previous units, the exercise you’re doing is vague intentionally so you can do it on your own. Some things to think about:
    Did you source your environment?
    Did you compile?
    Did you add the executable to CMakeLists.txt?
    Did you actually run the script with ros2 run?

  2. We actually offer a C++ course especially geared towards robotics. If you haven’t taken it, I highly recommend it:
    Learn Robotics from Zero - Robotics & ROS Online Courses

  1. I believe i did all the steps you mentioned above including ros2 run. It didn’t seems working. Btw, how can i delete the project and re-execute again? I will try again from scratch.

  2. I took the C++ course from Construct. Do you recommend any other cources?

Interestingly, it worked when i tried to launch the package this morning. The same ros2 run command did not worked other day.

Thanks for your response.

1 Like