Not a single thing in IDE, and catkin_ws all cleared out

Hi, so today when I login the IDE won’t show a thing (not even folder), and my previous works are all cleared out for course Basic Kinematics of mobile robotics. I don’t know what is going on, everything was fine last Friday.
I tried to create new packages in the wiped out catkin_ws but the IDE is still not able to recognize anything, I have refreshed several times but nothing apprears.


Sorry to hear that. This happens sometimes when there is an issue in the connection. The files should be there. Its normally a matter of 5 minutes or so to the files to download and be ready. If you refresh and let it load for 5 min, the files don’t appear? If you do an ls in the /home/user/catkin_ws/src path, your files are there? I’m asking to know exactly the issue and be able to solve it asap.

Hi, sorry I didn’t saw your message and then I have reworked everything from scratch again, the IDE eventually came back but the files never did, just when I was doing demo to my TA today it happened again, when I ls in /home/user/catkin_ws/src path there is nothing but a CMakeList.txt (which is the same as last time). luckily this time I had downloaded everything before demo so my day wasn’t ruined. I hope if you can take a look at my account to see if there is any problem because this is very unacceptable and it happened twice.


So I checked the latest version of the files of the course of BasicKinematics, and you didnt have any files, so soething went wrong when saving.

I checked the latets version that did have files in the /home/user/catkin_ws/src and I reinstated that version . You should , when starting that course have these files:

Checking the files of the Rosject generated from your course, it seems that you have created a workspace called “catking_ws” with G, which might have generated issues when redownloading files. I also detected that your catkin_ws had some problem in the source, which would maybe indicate that there was something wrong in the compilation and generation of the build and devel. Maybe you removed them and compiled an dhad some error? Or maybe sourced some other workspace?.
Please tell us inmediatelly if you are eperiencing any issue like this because it shouldn’t happen at all.

Sorry for the inconvenience

Hi, I did create a catking_ws by accident, after I lost my files the first time, before that I didn’t do anything in particular, this course didn’t require much compiling since it just run the python script through python so I didn’t compile that much as I can remember.
But I did delete devel folder in the ROS basics in 5 days course multiple times, due to some weird issues (new created topic won’t list, etc) that requires to compile from scratch.

Ok understood. So in theory is you dont source strange things you should be ok. Please tell us if you have any other issue