NO in actionlib

I am having problem when trying to launch the axclient at the end of the Unit 8 about ROS Action clients. Basically there’s no file named in that package.

user:~$ rosrun actionlib /ardrone_action_server
[rosrun] Couldnt find executable named below /home/simulations/public_sim_ws/src/all/actionlib/actionlib

I guess it’s not supported by Noetic yet?

user:~$ rosrun actionlib                                                                                  


Does that error still happen with the package actionlib_tools? If so, I’ll make sure to make that correction in the course.

I had the same error as @micheleciciolla2 , and I found in actionlib_tools (@roalgoal ). Unfortuantely, I am stuck again:

user:~$ rosrun actionlib ../actionlib_tools/scripts/ /ardone_action_server

Traceback (most recent call last):
  File "/home/simulations/public_sim_ws/src/all/actionlib/actionlib/../actionlib_tools/scripts/", line 256, in <module>
  File "/home/simulations/public_sim_ws/src/all/actionlib/actionlib/../actionlib_tools/scripts/", line 239, in main
    assert("Goal" in topic_type)
TypeError: argument of type 'NoneType' is not iterable

I also tried opening the graphical interface but it remains black.
Any ideas on what I am doing wrong?

Hi @mirlbeck, welcome to the community!

I find the command you are using unusual. To make sure that you have sourced the package that contains the axclient, try these commands:

source /opt/ros/noetic/setup.bash
rosrun actionlib_tools axclient

it doesn’t work too
what’s the point of don’t check out if something work?

The correct command is the following:

rosrun actionlib_tools <name of the action server>

For example, if you have launched the ardrone_as action server as indicated in the Unit 8, then you have to launch like this:

rosrun actionlib_tools /ardrone_action_server

The axclient is not very stable, so sometimes it just crashes. In case it crashes, just launch it again.