Navigation Rosject - keyboard_teleop command not correct

In the notebook for the Navigation rosject, we’re told to use
roslaunch turtlebot3_telep keyboard_teleop.launch
in order to navigate the robot and do the gmapping. A couple of problems:

  • There’s a typo - the package is turtlebot3_teleop (the ‘o’ was left out).
  • There is also no “keyboard_teleop.launch” file in that package. There is a “turtlebot3_teleop_key.launch” file. However it won’t run without specifying which model of robot - you just get an error message
  • I tried to pass in the model with
    roslaunch turtlebot3_teleop turtlebot3_teleop_key.launch model:="burger"
    but that didn’t work (nor did other variations I tried.
  • I ended up using export TURTLEBOT3_model='burger' . That finally worked


Fixed. Thanks for the feedback @comm .

Thanks @albertoezquerro. I just looked at my Rosject again. The notebook still lists the command as:
roslaunch turtlebot3_telep keyboard_teleop.launch
When I try it (but include the ‘o’ - in other words roslaunch turtlebot3_teleop keyboard_teleop.launch), I still get an error message saying it’s not a launch file.

I tried refreshing the notebook - that didn’t change anything. Is there something else I should be doing to refresh this?


You have to pull the latest changes by clicking on the red “i” button.

Apologies - I managed to completely miss that. Thanks for your help once again @albertoezquerro.