Login for bitbucket to clone repo?

On first step to get the source code for the GTest course, bitbucket asks for user name and password. I tried with no username/password, authenticate fail. I tried creating my own bitbucket account to have a login, authentication still fails. I searched the forum for some step I may have missed to no avail.

Any help/pointers appreciated. Thanks, John

Hi @johnfmoran ,

Welcome to the Community!

You need to create an app password with GitHub or Bitbucket which you can use in place of your account password.
This is the new practice. This was introduced a few years back.

If the repo is public, you may not require a username password to clone the repo.
If the repo is private, you need to create an account with bitbucket/github and clone it with username and app password (instead of password).

To know more about bitbucket app passwords visit link: App passwords | Bitbucket Cloud | Atlassian Support
To know more about github app passwords visit link: Creating a personal access token - GitHub Docs

I hope this helps.


I’m also doing this course right now and haven’t been able to pull the repo. I created a bitbucket account and generated the app password, but I got this error:

user:~/ros2_ws/src$ git clone https://bitbucket.org/theconstructcore/nav2_demo_test.git
Cloning into 'nav2_demo_test'...
Username for 'https://bitbucket.org': reallen
Password for 'https://reallen@bitbucket.org':
remote: The requested repository either does not exist or you do not have access. If you believe this repository exists and you have access,make sure you're authenticated.
fatal: unable to access 'https://bitbucket.org/theconstructcore/nav2_demo_test.git/': The requested URL returned error: 403

Hi @reallen ,

Going to this repo : https://bitbucket.org/theconstructcore/nav2_demo_test.git - shows that the repo does not exist.

I think only The Construct Team can fix this.


thanks @girishkumar.kannan, I did the app password as you suggested, but get same error as @reallen - and as you point out, the repo apparently isn’t there. at least I know it’s not something i’m doing wrong now, thanks for taking the time to answer, I hope this get fixed soon, as I would like to do the course! John

Hi @johnfmoran and @reallen,

apologies because somehow that repository was configured as private. I changed it to public so now you should be able to clone it successfully.



@rzegers - thanks! works now :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.