Local sim freezes the whole UBUNTU

Hey guys, I went through your courses and I wanted to install the parrot drone on my local PC

I got ubuntu 20 then installed ros noetic, python3 gazeboo 11.

I tried to run Mavros and PX4 stack and it is working fine.

But when I got following packages:
git clone --branch noetic Bitbucket
git clone Bitbucket

and then I do catkin build
and roslaunch drone_construct main.launch
I launches gazeboo and model correctly but after minute the whole computer freezes.
This is happeing only on the parrot model.

I tried to change params to load empty.world and the result is same.

Any ideas why?

No errors in console, the whole system is unresponsive (no clicking, or keyboard events)

This suggests a memory leak somewhere, eating up your PC’s RAM. You’ll need to find what is causing the memory leak (which package(s)).

You can also try catkin_make instead of catkin build:

# from your ros_ws
rm -rf build/ devel/

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.