IDE window is not working

IDE window has stopped working since I was learning “Python 3 for Robotics”. Now I started new course “ROS in 5 days”, but here same problem exit, IDE window is not working. I have tried all the solutions mentioned in the forum (like refreshing, re-load etc etc) but still problem not solved. Please help me to solve this problem.

Hi @zaidi.nzd,

If you have tried everything already, maybe there is something else you can try: Clear Local Storage

How to do that?

  • Press F12 on your Chrome to open the Developer Tools
  • Select the Console tab of the Developer Tools
  • Type localStorage.clear(); and press ENTER

Then reload the page. Maybe this solves the problem.

Which browser are you using? We support Firefox and Chrome. Please try on any of those and let us know.

Other browsers may work (for instance I use Brave), but it is not 100% sure all features will work.

I also use Safari on iPad and also works without a problem…

Let me also add that the IDE does not work in incognito mode.

If you are in a corporate environment, some network policies could block the IDE. If you cannot get it to work after looking at the earlier suggestions, please do the following so we can isolate the problem further:

  • Try another browser.
  • Try another PC entirely.
  • If possible try another Internet connection.

Please let us know.