I have an Error in my IDE

I have worked with topics 5 and 6 the last few days. And I always get the same error when following the tutorials.

In my IDE I get the error "unable to import …
“Unable to import 'trajectory_by_name_srv.srv”
“No name ‘EmptyResponse’ in module 'std_srvs.srv”

I have struggled with this for some time now. And do not understand how to fix it in this website/platform.

Hi Jørn,

I apologize for this error and for the trouble it has caused you.

It’s just something in the IDE and it will not affect your code. So please ignore it while we fix it. We are working on fixing this IDE error permanently.

So, has the issue with the class ‘EmptyResponse’ been resolved? Because while I am trying out the exercise 6.2, I need to be able to pass something to the service server. Like in the case of calling the service directly from the WebShell, I have tried keep the input as just ‘’ or but neither of them are accepted.
Could you recommend a workaround?

There was no real issue actually, it was just the IDE giving false positives regarding some “missing” files.

Please go ahead and do what you want to do and let us know if you run into any issues