How to fix Files and folders not displayed in IDE

My files and folders in the IDE are not displaying. I tried going to the other courses and they display the same problem as well. I tried looking it up online and saw that it is very similar to this.
However, there was no solution posted up there which could help.

Here is a screenshot for reference:

Hi @rshailly ,

Try doing “Add Folder to Workspace…”. Add the “catkin_ws” folder when the file explorer popup window opens.

That should solve your problem. Let me know if that does not work!

Regards,
Girish

Hi @rshailly

Did you try creating a file?

Sometimes the same thing happens to me, I just create a random new file and the whole directory appears again

@girishkumar.kannan @Voltedge
Thank you for your suggestions!

This is a known bug in the IDE application. We hope to fix it soon.

As a workaround, I have found that clicking of the Files (Explorer) icon to close it and then clicking on it again to open it works.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.