exercise_33 ERROR

ERROR: cannot launch node of type [exercise_33/publish_age.py]: can’t locate node [publish_age.py]in package [exercise_33]

Hi, sorry for the late response. This error could be a lot of things, like not having set the node as an executable. Can you post a little context on the error?

I found same error which says

ERROR: cannot launch node of type [exercise_33/publish_age.py]: Cannot locate node of type [publish_age.py] in package [exercise_33]. Make sure file exists in package path and permission is set to executable (chmod +x)

Hi, I’m Gonna need more information than that. Please share a screenshot of your package structure from the IDE, one of the possible issues is that, like the error says, your file publish_age.py is not executable. To fix this, go to the directory that contains the file and type:

chmod +x publish_age.py

I did chmod in the directory but it gave me the same error. This is the screenshot.

make sure the names matches, try changing the name of your script to be diferent than the launch file name. make sure the file is inside the rigth folder.

The names match and I also tried by changing the launch file to a different name. Same error appears.

Here is the path of my folder and the code.

if you would like, download and send me the whole package to have a better look:
u1802520@unimilitar.edu.co perhaps i can help

is your email correct? It is saying the address couldn’t be found. Can you check it, please

Please delete your package and go carefully through the instructions again. An error like this is common when you don’t use the correct names or if you forget to add the necessary additions to the package.xml (pay attention to the red notes)

hi @Henok if ran your package:


one little errror: at the begining of every python script you must add the python interpreter like so:

#!/usr/bin/env python

and make sure to run:

cd ~/catkin_ws
catkin_make
source devel/setup.bash
rospack profile

on every shell. everything else shoud be fine.

2 Likes