Exercise 3.1 Cant roslaunch

Hi,
I’m trying to roslaunch my package but getting the error. I ran python script directly, It worked but I cant roslaunch it. I attached my screenshot below. I think while creating the package I used the package dependencies as std_msgs instead of geometry_msgs I don’t know I might be wrong, If I’m correct what should I do to add the dependencies to the packages?
Thanks

try with : type=“move_robot”

I am not sure, I am also in the same course, but trying to help.

Hi @johnrebeiro,

Did you source the setup.bash file?

Yes, I did the same.

Maybe I understood my Mistake over here in the make packages I used std_msg but in the code use other msg that might be the problem, now the doubt how can we change the dependencies after making the packages?

Hi @johnrebeiro , welcome to the community!

Well, ROS nodes aren’t usually launched as a python script. You say you can’t use roslaunch, but have you tried rosrun? It is lower level, and if it doens’t work, you can know that the issue is how it is installed in your workspace.