Can't find menu bar in online "ROS Development Studio"


I follow the tutorial here:

But in section “Loading the Gazebo world using ROS”, it says “Option one: Click Simulation → …”, but I cannot find ROSDS menu bar in my browser window. Is it changed since you posted the tutorial?

What is the new way to load Gazebo world in your simulation environment?


Hello @kdong ,

Yes, that post is pretty old and the platform has been updated since then. The recommended method in order to launch a Gazebo simulation is the same process you would follow in a local computer:

  1. Download the simulation repository into your workspace (simulation_ws is the recommended one for placing all the simulation files). For instance: Bitbucket

  2. Compile the workspace

  3. Run the ROS command in order to start the simulation. Using the Turtlebot repository as a reference, for instance, one of the commands to start a simulation would be roslaunch turtlebot_gazebo main.launch.

  4. If you just want to open a Gazebo empty simulation, you can also type the command gazebo in a Web Shell and this will launch an empty Gazebo world.

  5. Finally, for some ROS distributions (it’s not available for all the rosjects), there’s also the possibility to choose the robot/world you want to use from the Gazebo menu (clicking on the Select a simulation option):

Captura de pantalla 2021-12-01 a las 10.28.17

This will open a page where you can select the robot/world you want to launch:

Hope this helps!

1 Like

Hi, Alberto:

Thanks for your reply!

I actually was able to start Gazebo, and can see the robot in the empty world. My question was how to control/move the robot. For example, in the local ubuntu ROS environment, there are a few tools on the Gazebo window to allow user rotate or tilt robot, but your web version Gazebo there isn’t any button at the upper edge of Gazebo. How do I use keyboard or mouse in this case to move the robot?


Hello @kdong ,

To move the robot you should publish into the topic /cmd_vel (the ROS topic used to send velocity commands to the robot). For instance, for the Turtlebot robot, you can run the following command:

roslaunch turtlebot_teleop keyboard_teleop.launch

This command will allow you to move the robot using the keyboard.

Hi, Alberto:

The problem here is the package ‘teeterbot’ doesn’t seem support teleop. What I did is:
$ git clone

After “roslaunch teeterbot_gazebo teeterbot_empty_world_pid.launch”, I got a simulation interface like in this image

As you can see I have a few buttons at the top of the world window where I can switch between “Translate mode (T)” or “Rotation Mode” etc. I can use mouse to move robot for each operation mode.

These tools are available if I run commands locally within Ubuntu machine, but NOT available if I run same commands within your web application. The control panel of web simulation gazebo is not available.

Did I miss any configuration to enable those control buttons for your web base simulation?


Forget to mention in above post, the web simulation was built based on Ros Kinetic. Not sure if this matters.

Hello @kdong ,

Can you share an image of what you get in our web application? You should also have those buttons available.

yes, this is what I got from your website Kinetic Rosject simulation. Rosject-Kinetic.

I cannot find any control buttons from the gazebo window.

I see. Could you please try to update your rosject to ROS Noetic? I think this might be an issue only for Kinetic rosjects. You can update the rosject version by going to the Edit page of the rosject and modifying the ROS Distro option.

Thanks, I will give it a try.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.