Cannot reserve a Robot [TurtleBot] in Real Robot Labs for +/- x:34 and x:45 time zones

Hi Construct Team,

I am unable to reserve a time slot for TurtleBot in the Real Robot Labs.

I am in the last chapter of ROS Basics in 5 Days with Python. I have completed all the three parts of Simulation (Pub/Sub, Services and Actions) - checked, tested and working. When I try to book TurtleBot, I do not get any time slots to reserve the robot. I checked for several days and all are just blank.

Can someone help me with this?

Also, I am from India. Does my country have any restrictions? Or perhaps if I use any VPN to access this website from European servers, would I be able to book a slot?

Thanks in advance,

Hi Girish,
that is strange you cannot book a robot. Everything is working properly.

Also, there is no restrictions for students from India. Additionally, in principle, you can use a VPN also without a problem (you will suffer a delay, but that is all).

Here there is the screen I get when trying to book right now. As you can see, there are some busy slots but also a lot of them free.

Can you show me a screenshot of what you get when you try to book a slot?
Also, do you know that you have only two 30 minutes slots per week? If you have booked already your two slots this week, you will need to wait until next week.

Hi @rtellez ,

EDIT: Tried using VPN also [using ProtonVPN with USA, Netherlands and Japan servers]. The result is still the same. I cannot see a time-slot under Turtlebot bookings. Perhaps there is some issue with my account that you people must look into.
Therefore, the attached screenshots are still valid and the problem remains, even with a VPN turned on.

MORE INFO: I tried to scroll through the day’s timeline [assuming there is a time zone mismatch] but even then I am seeing no slots available.

Here are my screenshots…

Please help me out!


Hi @rtellez ,

UPDATE: I am working on Ubuntu 20.04 Focal Fossa. I do not have a Windows Machine, nor can borrow one.
But either way, I tried it on Opera, Firefox and Chrome web browsers. Result seems to be the same. Cannot see any time slots to reserve the robot.

— Girish

maybe i’m having the same problem, i’m on windows 10


Sorry i was thinking that i can book a robot through that way. I did it where is supose to and i don’t have eny problem

1 Like

@bayodesegun and @rtellez ,
Could you give me an update regarding this issue? I am trying to book the turtlebot to finish my ROS Basics in Python course but for a long time I am unable to book it. This issue still persists as of writing this post on 25-Aug-2022.

Please help me out !


I’m checking that with the engineers. It doesn’t make any sense. We have checked that your account is running properly and that you can book robots.

We don’t understand what is happening. We are reviewing the code to see what may be the problem. Do not worry, we will extend your subscription by 2 extra weeks to compensate the trouble, so you will have time to finish the problem once we solve it.

I apologize for the inconvenience

1 Like

Hi @rtellez ,

Thank you very much for getting back to me.

Yes, it is very weird that I cannot reserve the robots. Glad to know that my account is working fine.
I am also planning to take all the certificate courses and the non-certificate courses as a part of the “Learning Path” programs. So I am sure to stay subscribed for at least 3 months.

Take your time, nothing urgent. But get it fixed early as much as you can. Thanks again for the update.

Meanwhile, I will be doing ROS Basics in 5 Days with C++ and start ROS2, perhaps, in both Python and C++.

Thanks and Regards,

Hi @girishkumar.kannan,

I suspect that it may be something related to timezone.

In the screenshot you shared, I see your timezone is UTC +5.5

Would be possible for you to try to set your timezone to a fixed number, like 6, or 5, and reload the page to see if goes ok?

1 Like

Hi @ralves ,

Sure, I will try that and get back to you shortly…


Hi @ralves ,

DUUUUUDEEEE !!! IT WORKED !!! I set my time on my computer to Berlin, Germany TimeZone UTC + 2.

You are a Genius !!! Thanks !!!

1 Like

A w e s o m e!!!

I’m really happy it worked!!!

I’ll now investigate our code to make sure it works with all “floating / possible” time zones.



@ralves , Yes, I think it is int / float issues in the code for time zones.

Anyways, (Formal) thanks again.
Girish Kumar Kannan


By the way, could you tell me the official name for the timezone UTC +5.5, @girishkumar.kannan?

For example, for UTC + 2, the official name is Berlin, Germany.

Having the official name would be easier for me to set up my PC at the same timezone and have the issue fixed.

Hi @ralves ,

Sure, it is Kolkata, India UTC + 5.5 hours (Indian Standard Time). That is how it is in Ubuntu. Not sure about Windows or MacOS.

Sorry for the late reply.

— Girish

1 Like


Thank you very much.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.

@girishkumar.kannan @ralves @AlfMachine
This issue has now been resolved.

  • You no longer have to give up your native time zone to book the real robot lab.

I apologize for the inconvenience so far.