Cambot is not above the turtlebot

When I execute the commands into my terminal 2, I am not receiving the “Message filter dropping message” error that I am supposed to see. My rviz2 file also does not show my cambot positioned above the turtlebot as supposed to, and I can still see my images.

This is the output I receive from my graphical interface when I run rviz2, different to how its supposed to look illustrated by the notebook since my cambot is not above the turtlebot.

Hello @HusamArdah,

please try to run this line before starting/launching Rviz2:

source /home/simulations/ros2_sims_ws/install/setup.bash

Please let us know if this solves the problem.



Hello, unfortunately it did not solve my issue. My graphical interface is still not showing the cambot positioned above the turtlebot. I also have not received the following message that I am supposed to see on my terminal:

`[INFO] [1647531775.937463391] [rviz]: Message Filter dropping message: frame ‘camera_bot_base_link’ at time 1631.230 for a reason ‘the time stamp on the message is earlier than all the data in the transform cache.’

I also seem to notice that when I begin the next task and run the “” file , I get results showing that my cambot frame is moving as supposed to, but not the cambot it self.

Hello @HusamArdah,

I understand, could you please provide a screenshot of your TF tree?

You would need to run these two commands, make a screenshot an post it here.

source ~/ros2_ws/install/setup.bash
ros2 run rqt_tf_tree rqt_tf_tree



Yes definitely, the photo below displays my TF Tree:

It seems to look pretty similar to the one shown in the notebook, but I am not too sure.

Hello @HusamArdah,

your tf tree looks good to me. I think I have found the issue. There is a gap in the instructions.

Once you execute this command here:

ros2 run my_tf_ros2_course_pkg

You start Rviz2 (make sure run source /home/simulations/ros2_sims_ws/install/setup.bash to that Rviz finds the meshes).

And the Rviz will load already configured. The instruction that is missing is this one:

Check that you have your Fixed Frame set to “world”.

Normally the fixed frame will appear as “chassis” and due to this you don’t see the robot move in Rviz even when it is moving in Gazebo. Changing the Fixed frame to “world” should solve the issue.

Hope this helps,


Thank you very much for the help.

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.