When entering commands, I am unable to type the entire code- Are there character limits?

Hi, I keep trying to copy and paste or type it myself as I want to copy a file into a new file, but once the code goes to the second line because its too long, it then doesn’t continue on normally as seen in the figure. For example, towards the end when I type copy.py it goes copyy.y. I have no idea why it is doing this or if there is a character limit maybe? Thank you so much for your help!


Maximize Web Shell and try again.

1 Like

Yes, that works! Thank you! It says that the directory does not exist. Does that mean that I would have to create the move_bb8_square_copy.py? I am following the instructions as it is, but it doesn’t say to make one with this name. However, I am not sure if it is implied. Thank you once again.

You are in the my_scripts directory of your package, you have to move back (cd …) to be in the directory where the file is. then try and copy the file.

if any of the replies solved your issu, tick the solution checkbox please.

Hi, Thank you. Yes, I tried that. I entered cd ~/catkin_ws/src/linux_course_files/move_bb8_pkg/my_scripts and then cp move_bb8_square.py move_bb8_square_copy.py and it says no such file or directory. I then created a new folder called move_bb8_square_copy.py and then I repeated the above, but to no avail. I get the same response. I am not sure what I am doing incorrectly. Thank you so much for your help.

This is because the file you want to copy is not in your current directory(my_scripts). From the image you shared it seems that the file is in ~/catkin_ws/src/linux_course_files/ (parent directory of my_scripts). you should navigate there and try copying your file.

cd ~/catkin_ws/src/linux_course_files/
cp move_bb8_square.py ./move_bb8_pkg/my_scripts/

Thank you so much! It worked! Okay that makes sense. I will keep practicing! Thank you once again.