URDF Quiz Score 7/10

Hello All, my URDF quiz score is 7/10 but I did not receive any error messages. I think my model is fine since the joint_state_publisher works perfectly in RViz and the robot moves successfully in Gazebo after running the move_joints python file. I got confused. Appreciate anyone who could help me!

Hello @tonyli19970130,

This happens sometimes when you have something running in the background (in the Web Shells). Try to stop all the programs you have running in the shells, and correct your Quiz again.

Best,

Hi albert, thanks for the replying. I close all the programs in the background and try again but still got 7/10. There are not any error messages showing up as well. Could you provide any further suggestions? Appreciate for your time.

Hi @bayodesegun, could you check on my URDF quiz package? I double check on my files and run the quiz correction for several time but still end up with a 7/10. I am pretty sure that I closed all the running programs during the quiz correction. Appreciate for your time!

@tonyli19970130,

Please give us some time to look into this. If you have other things to do, please move ahead with them. We’ll get back to you once we find the root cause of this issue.

Hello @tonyli19970130,

The problem with your Quiz is that is not loading the controllers. The check that is failing is the last point on the Specifications of the Quiz. Also, I’ve made a modification in the correction script that should make the error message appear in the Grader.

Best,

1 Like

Appreciate for your time, I will try again.

Hello @bayodesegun @albertoezquerro could you add some extra attempts for my URDF quiz? I only left one more attempt since I wasted several attempts but the system did not give any error messages before. Appreciate it.

Hi @tonyli19970130,

I have added 2 more trials for you.

Cheers,

Appreciate for that!

Hello @albertoezquerro Thanks for letting me know the problem. But when I run the launch file again, I believe all the controllers are loading successfully as shown below.

Besides that, I run the “rostopic list” in the second web shell and all the controller topics are showing up in the picture below.

But when I run the quiz correction, I still got the error saying that the controller topics are not loading. Could you provide any further hints on this problem? Appreciate for your time.

Hi. I have the same problem. Download of all controllers is performed by the file spawn_gurdy.launch. Topics appear in accordance with the specification. But when checking, the message "Control topics NOT FOUND"appears.
Снимок экрана_2020-07-08_13-04-42

Hello @bayodesegun @albertoezquerro , could you have a look at my URDF quiz package? @kongv1 and me have the same issue for " control topics NOT FOUND" even though all the controller topics appear correctly after launching the .launch file. I also use “rostopic list” command to double check for the controller topics and all of them appear correctly as well. I attached two pictures as a reference. Appreciate for your time.

I’m having the same issue. And I’m getting a 7/10 on the quiz, but the controller topics are in the launch file and the robotNamespace is included as /gurdy in the gurdy.urdf file.

Hello all,

Let’s go by parts:

First, @tonyli19970130, your problem is that you are not spawning the robot. In your spawn_urdf.launch file you have the following:

<launch>

  <!-- Load joint controller configurations from YAML file to parameter server -->

  <rosparam file="$(find my_gurdy_description)/config/gurdy_control.yaml" command="load"/>

  <!-- load the controllers -->

  <node name="controller_spawner" pkg="controller_manager" type="spawner" respawn="false"

    output="screen" ns="/gurdy" args="head_upperlegM1_joint_position_controller

      head_upperlegM2_joint_position_controller

      head_upperlegM3_joint_position_controller

      upperlegM1_lowerlegM1_joint_position_controller

      upperlegM2_lowerlegM2_joint_position_controller

      upperlegM3_lowerlegM3_joint_position_controller

      joint_state_controller"/>

  <!-- convert joint states to TF transforms for rviz, etc -->

  <node name="robot_state_publisher" pkg="robot_state_publisher" type="robot_state_publisher"

    respawn="false" output="screen">

    <remap from="/joint_states" to="/gurdy/joint_states" />

  </node>

</launch>

This is OK for loading the controllers, but you are not spawning the robot. So, without spawning the robot first, the controllers are not going to load properly. The spawn_gurdy.launch file has to:

  1. First, spawn the gurdy robot
  2. Second, load the controllers

Now, as for @kongv1, I just tested your package and got a mark of 10.

Probably, when you tried to correct your Quiz you already had a robot spawned in the simulation, or you had some program/s running on the Web Shells.

Finally, for @mccolgm, I couldn’t test anything because your spawn_gurdy.launch is wrong. The contents of your file are:

<?xml version="1.0" encoding="UTF-8"?>

<launch>

    <include file="$(find my_gurdy_description)/launch/spawn_gurdy.launch">

        <arg name="x" value="0.5" />

        <arg name="y" value="0.0" />

        <arg name="z" value="0.18" />

        <arg name="urdf_robot_file" value="$(find my_gurdy_description)/urdf/gurdy.urdf" />

        <arg name="robot_name" value="gurdy" />

    </include>s

</launch>

This is actually only including the same launch file (spawn_gurdy.launch) in the launch file, so it’s doing nothing.

Best,

Hello @albertoezquerro, thanks for the replying. I correct my spawn_gurdy.launch file and now I got 10/10 for the quiz, appreciate so much for your time!

Hi @albertoezquerro , thank you for your time. I didn’t really clear the simulator.:confused:
I’ll pay more attention in the future.

i am now able to spawn the gurdy robot, but i keep getting this error for the controllers:
Controller Spawner couldn’t find the expected controller_manager ROSinterface.

I’ve tried so many things! I’ve tried using both my gurdy_control.launch file and yours (by changing my path from my_gurdy_description to gurdy_description.

I finally tried spawning the robot and loading the controllers from your files. I went into
gurdy_description and ran roslaunch using your file spawn_with_controlers_gurdy.launch
and i got the same error.

HELP!

One more question - about the quiz - can you have the robot spawn from the spawn_urdf launch file and the controllers loaded from the gurdy_control.launch file or is everything supposed to be included in the spawn_gurdy.launch file?

did you setup the .yaml file for the controllers?

I got the controllers working. i needed to add ns="/gurdy" to the controller spawner. Quite frustrating. 5 hours to figure that out by comparing back to my mira files and scouring them for differences.