Unit 8 - package name 'gazebo_msgs' was not found before

Hello there,

Is there anyone that comes across the following compilation error in Unit 8?

`user:~/ros2_ws$ colcon build --packages-select bb8_cpp_unit_3_services
Starting >>> bb8_cpp_unit_3_services
--- stderr: bb8_cpp_unit_3_servicesCMake Error at /opt/ros/foxy/share/ament_cmake_target_dependencies/cmake/ament_target_dependencies.cmake:66 (message):
 ament_target_dependencies() the passed package name 'gazebo_msgs' was not
 found before
Call Stack (most recent call first):
 CMakeLists.txt:59 (ament_target_dependencies)

Failed   <<< bb8_cpp_unit_3_services [1.80s, exited with code 1]

Summary: 0 packages finished [2.07s]
 1 package failed: bb8_cpp_unit_3_services
 1 package had stderr output: bb8_cpp_unit_3_services

I have tried a few tricks, including adding the line <depend>gazebo_msgs</depend> as dependence in the package.xml file, but I always get the same error.

Hello @lgriera ,

You need to add the following line to you CMakeLists.txt file:

find_package(gazebo_msgs REQUIRED)

Add it where the other find_package() functions are located. You have to add this line so that ROS2 can find this package on compilation.