Unit 7 error. Status error when follow guidance on the path of the URDF file

In Step 5 of 7.2. Visualize Complex Data and RVIZ2, the platform shows some unknown errors which I cannot debug.

The images below happened when I updated the path of the URDF file to /home/simulations/ros2_sims_ws/src/neobotix_ros2/neo_simulation2/robots/mp_400

Its terminal in the same time shows constant error:
Warning: Invalid frame ID “map” passed to canTransform argument target_frame - frame does not exist at line 93 in ./src/buffer_core.cpp

Hi @PhongNguyen ,

Welcome to this Community!

What course are you working on?
I can see ros2_ws in the picture, but I am not sure if you are doing the C++ or the Python version.
I see that you have mentioned ROS2 Basics - Humble - Python.

From the Rviz output, I can understand that the Path to URDF file for RobotModel has an issue.
Probably you chose the wrong model by mistake.

I think your path is missing user after home.
Your path should read /home/user/simulation_ws/..........
I am not exactly sure of the path.

Also try switching between map and base_link in the FixedFrame property on the very top of the RViz Displays Panel.

Let me know if these steps fixes your problem.


I think the path of URDF file should be:


I tried switching between map and base_link in the FixedFrame property on the very top and it works.
The white model is because the robot don’t know where it should be.

Hi @PhongNguyen ,

Actually, the model becomes white if any of the robot model description files are invalid.
In your case, I guess the robot is white because the path in Description File is incorrect.

Also, please mark the appropriate post as “Solution” if your problem is solved, that way this issue can be closed.


1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.