Unit 6 fails to compile, and IDE shows errors when using provided code on ROS Manipulation in 5 Days

More details in the screenshot (error originally reported through email by @eyanagazi ):

Hi @eyanagazi,

Compilation Problem

I’ve been trying to reproduce this issue but I couldn’t.

When I tried, it always compiled.

The only thing that comes to mind is that your build and devel folders may be corrupt.

I would suggest you remove those folders and try to compile the workspace again, using the commands below:

cd ~/catkin_ws/

rm build/ devel/ -r

source devel/setup.bash
rospack profile

Could you tell me if that solves the compilation problem?

Errors in the Code Editor

Related to the errors in the Code Editor, thanks for letting us know.
It is really annoying to see those red lines, but thank God, those red lines are not real errors. It is just some misconfiguration from our (The Construct) side.

I’ve just added this red-line error to our list of errors to be solved. It may soon be fixed.

Please let us know if you were able to finally get the workspace compiled after removing the build and devel folders.

Hey @ralves I removed the devel folder, I compiled the package, I sourced the workspace then I refreshed the packages but I still have the same error

Hi @eyanagazi,

I see in the first screenshot that you were in the Unit 6 - Grasping, and the problem is that the workspace is not compiling.

Now I see you are having a different robot in the simulation, which means you are in a different Unit.

So my question is:

  • Could you be more specific on which Unit, and which section of the Unit you are having the errors? Telling us also which commands exactly you typed in the different terminals will help us help you better.