Unit 3 Launchings having the same error Cannot locate node of type

I am following the Exercise 3.1 instruction as I copied the code for “simple_topic_publisher.cpp” file,
and in launch directory, my launch file named:simple_topic_publisher_launch_file.launch with the code in the picture below:

and my CmakeLists.txt:

Also, for the Exercise 3.2, the move_robot.launch is having the same issue with my launch file is:

This is the error that I got:

I have checked all the launch files and .cpp file are executable.
I know it could be some dummy typo, so I have been checking all the file and node names but I couldn’t fix it. Could you please help me here?

I don’t know what is going on, but I am having the same error for every exercises for all Unit 3 and 4. I can build all the packages by catkin_make 100% successful. But I am always having the same error as above when I run the launch files
Can anyone please help?


try removing the build and devel , then recompiling and source. Also check that when you double tab, it gives you as suggestion the package:

cd ~/catkin_ws
rm -rf build devel
source install setup.bash
roscd topic_subscriber_pkg

Hi @duckfrost2 ,

Yes, removing build and devel fixed the problem.
Thank you very much!

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.