Turtlebot3 with open manipulator not appearing in gazebo in rosject


I’m trying to create a simulation using the turtlebot3 with the open manipulator, but I’m having an issue where the open manipulator arm is not appearing in gazebo.

I’ve created a new Melodic Rosject and I’ve git cloned the turtlebot 3 packages into simulation_ws.

git clone Bitbucket

With gazebo running (gazebo_ros, empty_world.launch), I’m loading the robot using:

roslaunch turtlebot3_gazebo put_robot_in_world_open_manipulator_tb3.launch

This puts the tb3 into gazebo, but the arm doesn’t (usually) appear.

Checking in RViz, the robot_model has loaded correctly. Also, gazebo is publishing joint_state data for the arm which is updating in real time.

I’ve tried creating a moveit package and the arm responds and moves, and gazebo provides new joint states which look correct, but the arm isn’t visible, nor does it have collision.

Strangely, the arm will very occasionally appear and work fine. However, it doesnt appear consistently.

I’ve seen other posts refer to .gazebo/models so I’ve checked and both the open_manipulator and turtlebot3 files are present.

Is there another method of getting the tb3 with the om to launch?
Or do I need to add the files in a specific way to .gazebo/models?

I’ve tried the same packages on a local ROS install and both the arm and tb3 appear every time.

The rosject is here:


Hello @constructrosteaching ,

Yes, this is definitely a gzweb-visualization issue. I’ve copied your rosject and did some tests, but couldn’t find the source of the problem, so it would need further debug. I can tell you though that we are working on fixing this kind of visualization issues in ROSDS for the future.