Trajectory_by_name pkg missing (Ex 3.4)

I reached example 3.4 in ros services 1 unit and the package does not seem to be available. i tried double tab roscd in the main directory and searched for the package but it is not available.

1 Like

Hello @omardg,

Thanks for reporting the issue. I’ve already found a solution and it will be pushed to Production for today.



Hi @omardg,

Welcome to the community, by the way!

Hello everyone,

This is issue has finally been solved and it should be working properly on Production. Please let me know if you still experience this issue or any other strange behavior. Sorry fhe inconveniences.


1 Like

I am doing the same example and have the same issue today. If get the following message:

Error: service [/trajectory_by_name] is not available.

When I execute:

rosservice call /trajectory_by_name “traj_name: ‘get_food’”

Apparently I must have missed something the first time. I ran through the exercise again on a different computer and it worked.

1 Like