Topics Quiz autograder

The autograder for the Topics quiz reports the following:

:heavy_multiplication_x: [17:16:14] [assess] Could not launch topics_quiz package successfully. Let’s squash this bug before we proceed further.
The launch command exited earlier than expected. Things your can check:

  • Did you name the launch file correctly? It should be topics_quiz.launch
  • Run ros2 launch topics_quiz and fix any errors that appears. (mark: 3.0)

My launch file is called as required by the instructions, not topics_quiz.launch as stated in the above bullet point.

When I run ros2 launch topics_quiz as stated in the second bullet point, I do NOT get an error and the robot successfully executes the assignment.

How to I move forward from this situation ?

Hi @versavel, welcome to our community!

Thank you for bringing this to our attention. The first bullet point must be a typo, since .launch extensions don’t exist in ROS 2, only or .launch.xml. We will update the instructions.

As for the autograder, do you still get marked as incorrect even if you run ros2 launch topics_quiz

1 Like

Please try again now.

I apologize for the trouble, but the way the gradebot was checking that point was not working consistently for some reason. I’ve adjusted it to check in a more predictable way.

The launch file name mentioned in the first bullet point has also been corrected.

1 Like

@bayodesegun @bayodesegun
[09:02:19][assess] Gradebot graded the Topics quiz correctly (mark: 10.0)

Thank you ! :raised_hands:

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.