The robot does not follow my commands Chapter 2

I just started the course. In the introduction I need to launch a file that will allow me to control the robot using some keys in the keyboard. However, when I try to do it, nothing happens in the simulation. The log shows the speed when I change it but the robot does not change its behavior, it only rotates in place counter clockwise at a pathetic speed.

This is the only line that write in the terminal:

roslaunch turtlebot_teleop keyboard_teleop.launch

And I try to use these commands:

Moving around:
u i o
j k l
m , .

q/z : increase/decrease max speeds by 10%
w/x : increase/decrease only linear speed by 10%
e/c : increase/decrease only angular speed by 10%
space key, k : force stop
anything else : stop smoothly

CTRL-C to quit

Hi, welcome to the community!

Please make sure that you click on the terminal where you launched the teleop so you can control the robot. If it rotates in place without sending any commands besides the teleop, then that means that it has worked.

Do you have any errors showing up anywhere? Please try again and let me know if it still doesn’t work.