The "/objective" topic;

Hey all,
I’m working on PhantomX Hexapod Perception Project and I’m getting trouble with the “Follow_Line” part.
My problem is that nothing is published in “/objective” topic. I got the following error. I got the same error when I run the solution code


Sorry for the late replay.

The objective topic has to be published by YOU. It states whihc colour of line to be followed, in this case green.

To publish it just execute this command in any other shell:

rostopic pub /objective std_msgs/String “data: ‘green’”

Take into account that the first time it launches and takes that topic you might get this error: >

Exception==list index out of range-yellow

(crop_img:1388): Gdk-ERROR *: 10:37:33.145: The program ‘crop_img’ received an X Window System error.
This probably reflects a bug in the program.
The error was ‘BadAccess (attempt to access private resource denied)’.
(Details: serial 484 error_code 10 request_code 130 (MIT-SHM) minor_code 1)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the GDK_SYNCHRONIZE environment
variable to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)
[my_hexapod_line_objective-1] process has died [pid 1388, exit code -5, cmd /home/user/catkin_ws/src/perception_course_solutions/hexapod_project_solutions/my_hexapod_perception/scripts/ __name:=my_hexapod_line_objective __log:=/home/user/.ros/log/15272942-a21c-11ed-a516-0242ac140006/my_hexapod_line_objective-1.log].
log file: /home/user/.ros/log/15272942-a21c-11ed-a516-0242ac140006/my_hexapod_line_objective-1
all processes on machine have died, roslaunch will exit
shutting down processing monitor…
… shutting down processing monitor complete

Its juts related to the Ubuntu system when its start s the session of the day. If you relaunch the sim and relaunch everything it should work, appearing all the images of line processing and the hexapod moving around.

Hope this helped and again sorry for the late response