TAB + TAB not autocompleteing

I have a question, i am just going thru the tutorial ROS2 basics in 5 days, and i remember a neat feature in ROS where you could press tab +tab button, and it would autocomplete, but for some reason it is not working, i am not sure what am i doing wrong? here is an example:

ros2 service call {then TAB + TAB should normally list all the available services calls} but it does not do that

another example:
ros2 topic pub {TAB + TAB} just freezes the console
it should normally list all the options available ?

if i type:
ros2 topic pub --once {TAB + TAB} freezes the console again

just does not work not to mention if you want to publish an empty /cmd_vel message just does not bring it up so you have to type the whole message by hand or copy paste
what am i missing?

Hi @ziga.rupret ,

I have finished that course and I have never experienced that problem.

I believe you are having that issue due to internet connection issues, I am guessing.

Try to reload the webpage (OR) try restarting the webshell by clicking on the red X button on the webshell’s tab. Once the webshell restarts, you can try that command with the auto-tab completion feature.

Let me know if this fixes your problem.


Hi thanks for the replay

But sadly no it does not work, i have went to the point of quickly installing ROS2 foxy on my ubuntu 20. to see if i will have the same issue, and i seem to have simmilar problems, i am using google chrome will rotate to win11 now and try it from windows i dont think it will make a difference but worth a try, at this point quick google search shows that this is a comon issue on ROS2?


ok in windows on chrome it works, will go back to ubuntu and try again maybe i am beeing du** :slight_smile:

Hi @ziga.rupret ,

I do not think this is a common issue with ROS2.

I have always worked on ROS1 and ROS2 with Ubuntu. I have tried ROS1 on Windows when I started, but I never liked the feel. I had several issues - this was few years back - during the times of Kinetic version.

Since ROS was first developed on Linux platform, I believe that ROS works best on Linux.


well not that comon but i did see some posts where people were saying thy were having problems with TAB TAB
yes it could be that i have not installed it correctly or i am having other problems as i just “speed” clicked/copied thrue the installaiton as i just wanted to test it out.

well just went back to ubuntu, loaded the tutorial in chrome and now it seems to work ok, i guess could be i was having connection issues/reloading ubuntu idk…

but it works now