RTABMAP in ROS problem

Hi guys,

In the tutorial, the RTAB-map does not work. I received this warning. However, after double-checking with rostopic info, it appears that one topic is not publishing, which is /camera/depth/image raw/compressedDepth; do you have any clue why?

/rtabmap/rtabmap: Did not receive data since 5 seconds! Make sure the inputtopics are published ("$ rostopic hz my_topic") and the timestamps in their header are set. If topics are coming from different computers, make sure the clocks of the computers are synchronized (“ntpdate”). If topics are not published at the same rate, you could increase “queue_size” parameter (current=10).
/rtabmap/rtabmap subscribed to (approx sync):

Please which unit of the course and what example/exercise are you working on?

The first unit is about building a launch file to run the RTAB-map configuration, and the second section is about mapping. The issue is that when I run the setup and attempt to map, the error shown below appears.

Unfortunately I still don’t get what you were working on.

Please give details of the commands you tried to run or what you were doing, with screenshots. Please include the screenshot of the point in the notebook you are trying to follow.

I solved the problem, I forgot to source the package.

Thank you,

1 Like