Rosbag Error Example 10.2


I amt trying to do rosbag play -l laser.bag and after I tried the rqt_plot /laser_scan/ranges[100]
but I don’t why I get a error saying that Plugin Manager could not load plugin. I aslo got a smiliar issue for the excerise 10.2 when I tried to add /joint_states/velocity[0] in rqt_plot.

my rosbag play -l laser.bag is running

Error Message

could anyone explain Like I where I got this wrong ??

Thank you in advance,

  • BG

Hi @balajigunasekeran22 ,

When you are playing the rosbag, do you see the robot move? Most probably it won’t.
You must pause gazebo physics before playing rosbag and unpause gazebo physics after rosbag playback is complete.

So, try launching rqt_plot with your rosbag after pausing gazebo physics. The error might be gone.

Let me know if you still have any issues.


Hi @girishkumar.kannan ,

I am still facing the error infact this error is happen even for my previous excerise too. I tried the above steps you mentioned


rosservice call gazebo pause physics


The thing is now I cannot see the /topic that I am adding in rqt_plot by using that + sign not only this rosbag excerise but also for the previous Plot topic data excerise because whenever I use the plus sign in rqt_plot I get an attribute error. Below is the my error in terminal when I run the Plot topic data excerise. I am using the /topic that is mentioned in the excerise but still I cannot add it into my rqt_plot and moreover It throws an attribute error what wrong am I doing here.

Thank you,


Hi @balajigunasekeran22 ,

You should never use roslaunch as an empty command. It always takes this general form:
roslaunch <package_name> <launch_file_name>.launch

You are playing pack from rosbag, so the order of commands will be:

rosservice call gazebo/pause_physics
rosbag play <rosbag_file>.bag
rqt_plot /laser_scan/ranges[100]

Also the error you are getting seems to be an internal issue with the rqt_plot program itself.
Here is the solution: rqt_plot noetic does not display arrays fields - ROS Answers: Open Source Q&A Forum

Solution (copy-pasted here for convenience):

To correct this you have to go the folder: “/opt/ros/noetic/lib/python3/dist-packages/rqt_plot/” and edit the file “” changing “string.atoi(str)” to “int(str)” (line 200)

I think your ROS version needs an update. I think The Construct team can help you with the update.

Which version of ROS are you working on?


Hi @girishkumar.kannan ,

Of course, I use the full roslaunch command with pkg_name and file.launch it was just to give to you an idea of steps I followed from your previous response.

And the ros version I use is ros noetic. Thank you clarifying the error in I tried to change the 200th line “string.atoi(str)” to “int(str)” but the thing is I don’t find this string.atoi function in 200th line. I think its time to contact the support team.

Thank you,


Hi @balajigunasekeran22 ,

Were you able to find any line that had “atoi” present in it?

– Girish

Hi @girishkumar.kannan ,

When I open in VScode I can’t see find atoi in my but when i do cat in terminal I can see atoi in the exact same line. But its the same file and even the file path is correct.


Hi @balajigunasekeran22 ,

Wow!.. That is weird. But at least we now know “atoi” exists in one file.

Try to use the terminal. Don’t use the IDE.
Open up the file using nano

cd /opt/ros/noetic/lib/python3/dist-packages/rqt_plot
nano ./

Now make the changes string.atoi to int. You just have to delete the two words and replace that with int. Do not change any indentations in the document.

Save and exit the document.

Press Ctrl+X to save the document. When it asks you if your want to save changes type in “y” for yes, and then hit enter.

Let me know if this worked after making the changes.


Hi @girishkumar.kannan ,

I tried the nano command which you suggested but that command was not found so I tried with sudo vim and edited the But still I cannot add the topic in rqt_plot and terminal still throws a similar error like the previous one.

Thank you,


Hi @balajigunasekeran22 ,

Then I guess, The Construct team has to look into this issue and find a fix.
Most probably update this rqt_plot package to a newer version on your virtual machine.

That’s all I can think for now.


Thank you @girishkumar.kannan for your help.

Hi @bayodesegun ,

Can you please help me with this Rqt_plot issue ???
Looking forward to hear from you.

Thank you,


Hi @balajigunasekeran22,

If you opened the file and in the exact same line it does not contain that string.atoi code, then it is probably loading some “compiled” file that ends with the .pyc extension.

Try to remove a possible dist-packages/rqt_plot/rosplot.pyc (if any exists)

Hi @ralves ,

There is no rosplot.pyc file in dist_packages/rqt_plot directory