ROS2 Navigation Rosject - How to generate TF Frame Tree or view it in rosject

Hi all,

I have a dump question related to generating TF Frame Tree in rosject
This is the first step of Navigation rosject and here are what I did:

Shell #1:

source ~/simulation_ws/devel/setup.bash
roslaunch realrobotlab main.launch

Shell #2

source /opt/ros/noetic/setup.bash
source /opt/ros/foxy/setup.bash
ros2 run ros1_bridge dynamic_bridge --bridge-all-topics

Shell #3 commands and output is like the below picture:

Did I miss something or where might I be wrong to Generate Files to Visualize the TF Frame Tree as the description?

Before running the command in Shell #3, run the following:

source /opt/ros/noetic/setup.bash
source /opt/ros/foxy/setup.bash
source /home/simulations/ros2_sims_ws/install/setup.bash

Hi @bayodesegun

I tried your commands first but the result is still the same.

Yes I have the same issue as well

1 Like

@HusamArdah @PhongNguyen
I apologize, it seems that the tf2_tools view_frames for ros2-foxy is not working for some reason. You can install that of Galactic and use it temporarily.

After running the previous commands, run the following in a separate shell only.

sudo apt update
sudo apt install ros-galactic-tf2-tools -y
source /opt/ros/galactic/setup.bash
ros2 run tf2_tools view_frames

If it does not work, close all programs running in the shells, then close all shells and start over.