ROS2 Navigation in 5 Days - Rosject - launch the ros1_bridge in the real robot

Hi there, i have a problem with my rosject. I would appreciate any help :slight_smile:

Right before starting with “SECTION I: Mapping” the ros1_bridge should be launched.

The following commands should be executed:

source ~/catkin_ws/devel/setup.bash
roslaunch load_params load_params.launch
source /opt/ros/foxy/setup.bash
ros2 run ros1_bridge parameter_bridge parameter_bridge

I splitted them up into two terminals:
Terminal 1:

user:~$ source ~/catkin_ws/devel/setup.bashROS_DISTRO was set to 'foxy' before. Please make sure that the environment does not mix paths from different distributions.user:~$ roslaunch load_params load_params.launch
... logging to /home/user/.ros/log/71d656fc-47ff-11ee-8272-0242c0a81006/roslaunch-2_xterm-13778.log
Checking log directory for disk usage. This may take a while.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://2_xterm:44011/


 * /rosdistro: noetic
 * /rosversion: 1.15.11
 * /topics: [{'topic': '/tf',...


auto-starting new master
process[master]: started with pid [13816]

setting /run_id to 71d656fc-47ff-11ee-8272-0242c0a81006
process[rosout-1]: started with pid [13835]
started core service [/rosout]

and Terminal 2:

user:~$ source /opt/ros/foxy/setup.bash
user:~$ ros2 run ros1_bridge parameter_bridge parameter_bridge
/home/simulations/ros2_sims_ws/install/ros1_bridge/lib/ros1_bridge/parameter_bridge: error while loading shared libraries: cannot open shared object file: No such file or directory

Can anyome tell me what my mistake is?

Tanks in advance!

Hi @TimSch ,

Just ignore this line: roslaunch load_params load_params.launch.

So the correct order of commands will be:

source ~/catkin_ws/devel/setup.bash
source /opt/ros/foxy/setup.bash
ros2 run ros1_bridge parameter_bridge

Let me know if this fixed your problem.


@girishkumar.kannan Tank you very much for your reply! I will try so and will let you know if it has worked :slight_smile:

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.