ROS2 Basics in 5 Days Humble (C++) - 4.7 Services Quiz

i finished the Unit 4.7 Quiz and my Code for the services_quiz and for the custom interface services_quiz_srv works as specified in the description. But unfortunately the gradebot fails me after the build.

and when i do the build everything is fine:


Hmm, that seems strange. Did you ensure that nothing was running in your terminals? Are you able to submit again? If not, let me know so we can investigate further

Hi @roalgoal,

i have only one submisson left. I can try to submit again. I will tell you if it worked or not.

Hi @roalgoal,

again there is the compile error from the gradebot. And now my submission trials are empty i got 5/5 trials .

Hello @mosgaed ,

I’ve been doing some tests and I’ve seen there are some things not working correctly in the autocorrection system. I need to do some more tests to figure out exactly what is going on. I’ll let you know later today once I have it fixed. Meanwhile, please keep advancing with the rest of the course. Don’t worry about the trials, I’ll reset them for you.

Hi @albertoezquerro,
thank you for your help.

Hello @mosgaed ,

Could you try to compile your whole workspace before submitting the Quiz?

  1. Go to the root of your workspace:
    cd ~/ros2_ws/

  2. Compile:
    colcon build

If you don’t get any compilation, submit the Quiz then. Let me know if it works Ok now.

Hi @albertoezquerro,
this is now the log after build:

Hi @mosgaed and @albertoezquerro

I have the same error and I can’t find the solution too.

Topic Title: Failed to create symbolic link - Services Quiz

In ROS2 Basics in 5 days Humble (Python) I have the same error and I can’t find the solution too.

Although the packages were compiled before being submitted to GradeBot (services_quiz_srv no errors, services_quiz with a warning message but no errors).

Hello everyone,

I downloaded @mosgaed packages and they compiled fine in my workspace, so I assume you must have something wrong in your ROS2 workspace. Let’s try removing the current compilation files and building again:

cd ~/ros2_ws
rm -rf build/ install/ log/
colcon build

@oleg.a.kuvaev and @Voltedge You can try this too. Please let me know if it solves the error.

I was also testing in @oleg.a.kuvaev environment. I solved this issue by removing the current compilation files and rebuilding the workspace, as indicated previously:

cd ~/ros2_ws
rm -rf build install log
colcon build

Also, I saw that he had some compilation files inside ~/ros2_ws/src :

This is not correct. You MUST only compile in the root of the workspace (/home/user/ros2_ws) and nowhere else. So all the compilation folders/files that are outside the root of the workspace must be removed.

Greate :smiley:
My solution for this mistake:

  1. cd ~/ros2_ws and rm -rf build install log
  2. colcon build
  3. Verify in simulations
  4. Again cd ~/ros2_ws and rm -rf build install log
  5. Sent to GradeBot WITHOUT colcon build

Profit :slight_smile:


@oleg.a.kuvaev & @albertoezquerro

Thank you guys for your help and informations! This worked for me aswell!

hi @albertoezquerro , @mosgaed @oleg.a.kuvaev

In my case still appears

[0.576s] WARNING:colcon.colcon_ros.prefix_path.ament:The path'/home/user/ros2_ws/install/services_quiz’ in the environment variable AMENT_PREFIX_PATH doesn’t exist [0.576s]WARNING:colcon.colcon_ros.prefix_path.ament:The path’/home/user/ros2_ws/install/services_quiz_srv’ in the environment variableAMENT_PREFIX_PATH doesn’t exist

I send the solution to gradebot and appears the same error “failed create symbo link”
What else can I do?

Thanks @oleg.a.kuvaev your solution works to me too!


This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.