ROS1 - ROS2 bridge problem in Course Project (Rosject)

When I am trying to run the ROS bridge command, I get the error “Failed to read a response from a service center” and “Failed to look up /ros_bridge/set_logger_level”. I can’t launch my package until I am able to fix this bridge. Does anyone know how to fix this?

Hi Adam,

Welcome to the Community!

It is hard for us to tell if we don’t know what you are trying to do. Which unit/section of the course are you trying to follow?

If it’s a personal project, then you need to give a bit more details. Is the simulation running? Are there other dependent packages/scripts that might need to be started?

The simulation now stopped running. I can’t run the project at all anymore because all the simulation files are missing. My Jupyter Notebook also doesn’t appear anymore so I really can’t do the project. I was working on Part 1 of ROS2 in 5 Days (Python) Class Project.

What do you mean by “all the simulation files are missing” and “My Jupyter Notebook also doesn’t appear anymore”?

Please tell us exactly what you are seeing, with screenshots.

When I enter the project for this course, I can’t see my code (part1_pkg) and I can’t run the simulation because the world file is missing. I also can’t see the project instructions in my jupyter notebook.

Oh, I get. Let me see what happened to your project file.

I have restored a previous, complete, version of your rosject. The was some mix-up while saving the latest version.

Please check it again now. Sorry for the glitch.

Hi now my environment works but I still get this error when I run my code:

I think it is because my ros2 - ros1 bridge command didn’t run properly (I had to press ctrl-c because it got stuck):

This error suggests that you are using a ROS1 message type instead of ROS2. In your, are you importing ROS2 messages?

The command is colcon, not colocon. :wink:

Hi so when I try to run the ROS bridge command:

ros2 run ros1_bridge dynamic_bridge --bridge-all-topics

The program times out and then when I press ctrl-c I get this error:

It doesn’t look like it timed out, those [INFO] messages are saying that the connection in the bridge was made. You can check if this worked in another terminal and checking the topics (ros2 topic list)