ROS1 Bridge does not work in ROS2 C++ Rosject


When I paste the following command in the Shell, like it is mentioned in the Notebook.

source ~/catkin_ws/devel/setup.bash
roslaunch load_params load_params.launch
source /opt/ros/foxy/setup.bash
ros2 run ros1_bridge parameter_bridge

The code does not work.
It keeps stuck after the roslaunch load_params command

So I can not continue to do the ros1_bridge command.

I tried with the Gazebo Simulation running and without. Same result.

Does someone have an idea, what the problem could be?

I have the most recent rosject updated.

Thanks for any help.


I apologize for that glitch. I can confirm that it’s happening.

Could you try to ignore that part and continue with the rest of the notes?

It seems that the ros1 bridge is not needed anyways, and that part needs to be removed from the notebook (let me confirm from the subject matter expert in charge of it).

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.