Ros not working! and src folder content deleted


Before my last log off I started to look at the UDRF tutorial. I’m not sure if that may have caused this glitch.

I was working on lessons in ROS for Beginners 5 days course and I logged in today and found that all my stuff in catkin_ws/src was deleted. I did not deleted them.

After looking around a bit I tried to redo the examples and I found that ros is not available to me. When I tried to roslaunch the examples it did not work.

As you can see ros is not initiated in the shell. If I switch to the UDRF 8 hour course ros is re-initiated and when I run the UDRF examples with roslaunch it works. So I am wondering if this can be fixed because I want to finish the Ros Basics course. Also is there a way to restore my files back or do I have to make new files.

Thank you

We are checking your problem

1 Like


Welcome to the Community! I apologize for this glitch, we are working on preventing it in the future.

I have restored your ROS Basics in 5 Days course files. You should find them the next time you load the course. And, also, the ROS commands should work.

1 Like


Thank you for looking into my problem. I have restarted The Construct
However I am still unable to get things to work.

I did,
$cd catkin_ws/
$source devel/setup.bash

I am receiving new errors instead:

Also the files are still missing.

Thanks again,


I will reset your VM so you get a fresh start. Please save your work and let me know when I can proceed with the reset.

1 Like


I see that you have been inactive for some time and the system has closed your current VM. The system will automatically assign you a new VM when you come back. Please let us know if you are still having the problem then.

1 Like

Hi again,
I have logged back in. Unfortunately the problem still persists.

Regarding the missing files. I was on unit 4 when the error occurred so there should be a couple of packages and folders. To be honest I don’t mind redoing them. But having them back would be nice.

Very strange. Sorry for the trouble. Let me look into it again.

1 Like

The issue is that for some reasons your workspace files are not downloading properly, so the ROS environment cannot be correctly prepared.

We are looking into why this is happening. I’m able to connect to your VM and download your files. In the meantime when you connect again could you please check the following:

  1. Ensure you are not behind any proxy of firewall that could be blocking or slowing down your connection.
  2. Wait a bit for your files to appear in src before you try to launch any command?
  3. When the files appear, run the following commands:
cd ~/catkin_ws/
source devel/setup.bash
rospack profile

Thanks for your patience.

1 Like


Thanks again for the fix.
Everything seems to have been restored and working fine.

I will let you know if anything else seems to need a fix.
I think we can consider this fixed.

Hi @cjlazar ,

after some investigation, we found that more than one rosject save processes were running in parallel.

We modified it so that only one process runs for a given rosject.

Please let us know in case the problem happens again so that we can look further on this issue.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.