ROS Developers Extra Class n2

Where is the roject located that i can fork that u use in this class? I cant find it.

Hi @badmadafaka ,

I just found the live class, it is listed in the Live Classes page

Let me know if that works for you!


thanks, the i cannot fork the projekt tho:

Hi @badmadafaka ,

I just fix the correct link to this rosject, you should be able to fork and run it now

Please let me know if not


Thank you, I can fork it and everything now. However, I cant get the simulation to run. I think there is a bug. Are you willing to try, to see if it works for u?

Best regards

Hi @badmadafaka ,

I tried to recompile the packages with the following commands

source ~/home/simulations/public_sim_ws/devel/setup.bash
cd ~/simulation_ws/
source ~/simulation_ws/devel/setup.bash
cd ~/catkin_ws/
source ~/catkin_ws/devel/setup.bash

It may be necessary if the workspaces had some inconsistency in its compiled files.

Finally, I tried to launch the simulation but I still get another error.
We are working on it to figure out the issue.

Thank you for your patience, sometimes after updates in the platform, we need to adjust some of these old rosjects.

I’ll get back with a proper answer as soon as I have it


Thank you, how long do you think it will take? Because I need it for an assignment, and if its not a quick fix, i will make it somewhere else.


Can I get an update?

Hi @badmadafaka ,

Thanks for your patience. Unfortunately we still don’t have a solution, our team is working on it.