ROS Basics in 5 days Python Real Robot Project - roscore not running properly

Hi there, My name is Jacob I am new to this community :slight_smile:
I see there is great people helping here I have issue I couldn’t find solution in the forum .

While in section 2 of project.

I tried to call rostopic list - and got an error - “ERROR: Unable to communicate with master!”

So I Launched roscore

But I don’t have any of the required topics like for gazebo or other ones this is what I get when running rostopic list (after roscore running)

Hi @jacob17.y

Welcome to the comunity! Which command do you used to start the roscore?
Can you show the shell response?

Hi @jacob17.y ,

Welcome to this Community!

You will only see those two topics [/rosout and /rosout_agg] if you have not launched the simulation.

Also, you got this error: “ERROR: Unable to communicate with master!” - because your simulation was not running - because it was not launched.

DO NOT LAUNCH roscore by yourself. roscore will be launched automatically when you launch the simulation.

To see the topics you must first launch the simulation as described in the rosject notes.

Run the following command on a terminal and wait for the Gazebo window to show up.

roslaunch realrobotlab main.launch

Once Gazebo has launched, then on a new terminal type the following command
(do not close the old terminal, leave it running),

rostopic list

Now you will be able to see all the topics attached to the robot!

Hope I clarified your doubts. Let me know if you still have issues.


i understand. thank you both
*roslaunch realronbotlab main.launch this command didnt work it said it didn’t recognize it so as rostopic list

so I tired something else I did

source /opt/ros/noetic/setup.bash
source ~/simulation_ws/devel/setup.bash

and now it works but I actually don’t understand what I did here what does sourcing the setup means? why can’t find it by itself?
and will be happy for some info

Hi @jacob17.y ,

That was my stupid typo blunder. Sorry for that. I have now fixed it on my earlier post.

Anyway, here it is again (spell checked twice):

roslaunch realrobotlab main.launch

You have the same exact line on the rosject notebook notes. If my command did not work, you could have at least copy-pasted it from the rosject notebook!

If you are working on a ROS(1) rosject, you do not have to source your ROS version. It is already done for you every time you open a fresh terminal window.

You are basically selecting the version of ROS on the computer to execute the package you wish to run.
You can have more than one version of ROS installed in your computer. You can also have ROS2 installed along with ROS(1). So, sourcing will just help your computer understand which ROS version to execute your package.

This is already done in your ROS rosject. Every time you open a terminal window, ROS version is sourced automatically. This is only in the ROSDS environment. This may not happen in your own personal computer.


Thanks you for the detailed explanation
this what happens if i dont do the source every time

Hi @jacob17.y ,

I think there might be a problem with your rosject files.

Try to delete the rosject and fork it again.

To delete: Go to your homepage, go to My Rosjects, click on the ROS Basics Python Rosject and once the popup window loads, you can find the red “trash can” symbol. Click on this symbol to delete the rosject.

To fork the rosject again: Open ROS Basics in 5 Days Python course again. Go to any of the chapters that tell you to “click the link” to get a copy of the rosject. Get a new version of the same rosject again.

I hope this solves your problem.

Let me know if this does not fix your problem!


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.