Real robot not working in ROS2 Navigation course


I tried to run the mapping, localization and path planning launch files in the real robot but it does not work. When I try to launch the localization launch file it gets:

submap_slices and last_frame_idis empty

In addition, it said:

[cartographer_node-1] [INFO] [1697574016.159735668] [cartographer_ros]: I1017 20:20:16.000000 7932] Found ‘/home/user/ros2_ws/install/project_mapping/share/project_mapping/config/cartographer.lua’ for ‘cartographer.lua’.

but the Cartographer does not work now, it worked before, but the map has changed and I need to remap again.

Any ideas?

I lost my real robot session for this.

My best,

It’s very strange that no tf data is received. I assume you checked the robot was working correctly because I checked just now and I receive tf messages. If you didn’t check, this is what you can do:

  1. Are you able to receive tf messages in ROS 1? you can echo the topic to check. What about scan, can you move the robot? If this works, then you can discard the robot not working as the issue.
  2. Next you can move to the ros1_bridge. Is it running? Is it actually bridging the topics you need? what happens when you check ros2 topic echo /tf?

It makes sense that cartographer_ros doesn’t work if there are not TFs. So the challenge becomes finding the reason why you are not receiving the data that the robot is supposed to provide. If you find that the robot does in fact not respond, please let me know.

You now have an extra session


I sending you a screenshot including the output of the ros bridge which I think does not work properly:

And of course the /tf topic does not exists. I can drive the robot using the joystick, but not using the keyboard.

any ideas?

this is the second time I lost my real robot session.

I just tested on the robot with the course rosject and everything went fine:

:eye: Note the output in the ros1_bridge terminal, a succesful bridge connection should look like that. In your case, there are no connections made.

If you correctly followed the instructions, including running the bridge in a fresh terminal, then the most likely reason for your error is that your rosject’s documents (specifically, the catkin_ws) are corrupted.

:green_circle: What you can do is download all of the work you have done in ros2_ws/src and refork the course rosject:

:broom: Once you do that make sure to delete the corrupted rosject so you don’t get confused :broom:

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.