Real robot lab problem

Can someone check that if there is something wrong with reading the odometry of the real turtlebot3 robot? In the following picture, when I enter rostopic pub /odom, it gives me the following output:

It can be easily seen that it doesn’t give me the correct position and orientation.

You can also compare between the following outputs, the first one is in the simulated robot, and the second one is a real robot:


Thank you for bringing this to my attention. This was an error with the TurtleBot3 Hardware, and it is now fixed. Please let me know if this problem persists, as this will tell me that a hardware change is necessary.

Thank you,

Yes, this problem still exists now.

@roalgoal, I can also confirm that odometry is not working correctly (topic /odom). There is also something strange on topic regarding wheel status (positions/velocity/effort) - position is fixed while velocity is unstable around 0.5 even if the /cmd_vel is set to 0. I guess that there must be a hardware problem, probably with encoders?

Thank you for letting me know. The turtlebot will be replaced today, so that should take care of the hardware problems.

@roalgoal, I am sorry, but /odom is still returning 0 for pose.pose.positions. Also, I had some problems with the connection between the robot and the joystick which I solved by reconnecting to the robot. While moving in a straight line motion of the robot was quite jerky, as that joystick was “losing signal” and randomly sending 0 while velocity in twist was 0.1.

Hi, you are correct, the odometry topic is still not publishing. Sorry for the inconvenience, we will replace the hardware as soon as possible. I will let you know as soon as it is done.

In the meantime, if you are working on a course rosject, you only need to show that the sections that need odometry work in the simulation.

Well, simulation is perfect, it always works =)

I hope that the problem will be solved soon.