Real Robot doesn't work

HI, I am starting to connect to TurtleBot and it is still charging. I tried connecting and disconnecting multiple times but still the same, is there a problem?

Hi @Voltedge ,

If you are referring to the joystick not being available as “charging” then you are mistaken.

Sometimes, the joystick does not work. This has happened to me some time back. Although this does not happen too often. When when it does happen, open up the teleop program from your terminal to move.

DO NOT be dependent on the on-screen joystick. When it does not load, ditch the idea and use teleop!

The robot, I believe, is permanently connected to power supply. So the robot is never halted for charging, unless unplugged.

I think you wasted a session waiting on joystick, unfortunately.

When you are unsure if robot is working or not, do topic list.

rostopic list  # if using ROS1
ros2 topic list  # if using ROS2, make sure to use ros1_bridge

If you get several topics in the output then the robot is working else it is not.


Hi @girishkumar.kannan

I think I explained myself wrong, during all that time, the odometry, scan and other buttons that I don’t remember the name did not appear either. It just stayed that way.

On the other hand, I also tried to use the topics and run my program like that and it didn’t work either.

Hi @Voltedge ,


If the above image never appeared for you then it is a problem!
This has also happened to me once if I remember correctly.

I am sure TheConstruct team would help you out with this.

Yes, that is true. If the status does not load and turn all green, topic list will not produce a (good) result.
I have noted this too.


That issue is very strange. Please try again in about 1 hour and let us know if you still have any issues.

Hi @bayodesegun , @girishkumar.kannan

Could one more attempt be enabled? I no longer have any more reservation spaces for this week

I have enabled two more attempts for you. Please book again for some time later in the day (3 hours from now), as we need to look into the connection issues currently happening.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.