Pydy install problem on chapter 3 of Robots Dynamics and Control

I cannot test my developments of Unit 3 in this course, because when I try to install pydy with pip an error occur. Here I paste the error code I am receiving.

user:~$ pip install pydy
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at pip 21.0 will remove support for this functionality.
Defaulting to user installation because normal site-packages is not writeable
Collecting pydy
  Using cached pydy-0.6.0.tar.gz (19.1 MB)
Requirement already satisfied: numpy>=1.16.5 in /usr/local/lib/python2.7/dist-packages (from pydy) (1.16.6)
Requirement already satisfied: setuptools>=44.0.0 in /usr/local/lib/python2.7/dist-packages (from pydy) (44.1.1)
ERROR: Could not find a version that satisfies the requirement scipy>=1.3.3 (from pydy) (from versions: 0.8.0, 0.9.0, 0.10.0, 0.10.1,0.11.0, 0.12.0, 0.12.1, 0.13.0, 0.13.1, 0.13.2, 0.13.3, 0.14.0, 0.14.1, 0.15.0, 0.15.1, 0.16.0, 0.16.1, 0.17.0, 0.17.1, 0.18.0, 0.18.1, 0.19.0, 0.19.1, 1.0.0b1, 1.0.0rc1, 1.0.0rc2, 1.0.0, 1.0.1, 1.1.0rc1, 1.1.0, 1.2.0rc1, 1.2.0rc2, 1.2.0, 1.2.1, 1.2.2, 1.2.3)
ERROR: No matching distribution found for scipy>=1.3.3 (from pydy)

Thanks in advance for your help.

I apologize for this glitch. We are working on it and will get back to you shortly.

Thank you! I’ll wait until you confirm me I can install it

This problem is still not solved.

Hello @misbahsuhail123 ,

It’s no longer required to install pydy in this unit. Can you specify what issue are you having?

Yes no need to install now. Thanks for your help. :slight_smile:

1 Like

This topic was automatically closed after 21 hours. New replies are no longer allowed.