Problem controllers - Manipulator arm (ROS noetic)

I created a robot arm standing upright.
When I run the gazebo everything is normal but when I try to move one of the controllers all the arms fall down and I can’t move them anymore. When I run rosservice call list_controller I get an error.

user:~$ rosservice call /mira/controller_manager/list_controller

ERROR: Service [/mira/controller_manager/list_controller] is not available.

I am just getting started and I noticed that when the PID values are close to 1, the arms drop right after starting the simulation, and when these values are increased, I am dealing with the problem given in the title.
Thank you in advance for your help

Hi @befard

Welcome to the Community!

Could you please let us know the course and the unit you are taking?


In the URDF for Robot Modeling course, after completing the tutorial based on the Mira robot, I modified the my_mira_description package to create a robot arm, I thought that if I expand it and stick to the instructions on how to create a Mira robot, everything should work