Preparing rosject files taking a very long time

Hello, I wanted to create a project with ROS for a class, and when I went to create a new project, it’s been stuck on a “Preparing rosject files…” loading screen for over 30 minutes. I’m afraid this is going to eat into the ROS project time people have been mentioning on these forums, I’ve tried reloading the website, turning off adblocker, turning my computer off and on, I tried the tutorial module (which worked), I tried using a different version of ROS, and I tried making a new project but still no results. Maybe I’m just being impatient, but any advice would be seriously appreciated. Here’s the loading screen for reference:

1 Like


Sorry to hear that . Could you try again now. I just tried to cretae a noetic empty rosoject and it worked. Could you tell us exactly the versions of ros you selected and if it wa sprovate or public ? Is to know what could have gone wrong there.

I have the same problem at the moment. The rosject was working perfectly, but now I want to open and it never stops loading. I use ROS Kinetic. I tried to log out & log in, didn’t help, cleaned all history, cookies, etc of the browser, didn’t help… :frowning: Any clue?
Thanks a lot in advance.